re = /(.*?)\((.*?)\)/x
str = 'int AddNumbers(int x, int y) { return x + y; }
int AddNumbers(int x, int y);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end