$re = '/(.*?)\((.*?)\)/x';
$str = 'int AddNumbers(int x, int y) { return x + y; }
int AddNumbers(int x, int y);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);