package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?)\((.*?)\)`)
var str = `int AddNumbers(int x, int y) { return x + y; }
int AddNumbers(int x, int y);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}