re = /^[a-zA-Z\s,.'\-\pL]+$/m
str = 'Auðbjörg Reynisdottir Krišjānis Gāle Pierre Bérégovoy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end