package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z\s,.'\-\pL]+$`)
var str = `Auðbjörg Reynisdottir Krišjānis Gāle Pierre Bérégovoy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}