$re = '/^[a-zA-Z\s,.\'\-\pL]+$/m';
$str = 'Auðbjörg Reynisdottir Krišjānis Gāle Pierre Bérégovoy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);