// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(-?)\d+(\.?(\d+?)?(\w+))?").unwrap();
let string = "-1
-1.2
-1px
-11.35px
1
1.2
1px
11.43px
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}