package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(-?)\d+(\.?(\d+?)?(\w+))?`)
var str = `-1
-1.2
-1px
-11.35px
1
1.2
1px
11.43px
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}