#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(-?)\d+(\.?(\d+?)?(\w+))?"
Local $sString = "-1" & @CRLF & _
"-1.2" & @CRLF & _
"-1px" & @CRLF & _
"-11.35px" & @CRLF & _
"1" & @CRLF & _
"1.2" & @CRLF & _
"1px" & @CRLF & _
"11.43px" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")