$re = '/(\+?(\b1)?[\ .\/-]?((?(2)|(\b))|(\())\d{3}(?(?<=\(\d{3})\)|)[\ .\/-]?)?(?(1)|\b)\d{3}[\ .\/-]?\d{4}[\ ]?([xX][\ ]?\d{1,5})?\b/m';
$str = '+ (513)899-1888
5138991888
8991888
1 5138991888
+5138991888
(513)8991888
1(513)8991888
(5138991888
+1 513-899-1888
1/513-899-1888
1(513)899-1888 X 8888
+1 513 899-1888 x 11111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);