import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\+?(\\b1)?[\\ .\\/-]?((?(2)|(\\b))|(\\())\\d{3}(?(?<=\\(\\d{3})\\)|)[\\ .\\/-]?)?(?(1)|\\b)\\d{3}[\\ .\\/-]?\\d{4}[\\ ]?([xX][\\ ]?\\d{1,5})?\\b";
final String string = "+ (513)899-1888\n"
+ "5138991888\n"
+ "8991888\n"
+ "1 5138991888\n"
+ "+5138991888 \n"
+ "(513)8991888\n"
+ "1(513)8991888\n"
+ "(5138991888 \n"
+ "+1 513-899-1888\n"
+ "1/513-899-1888\n"
+ "1(513)899-1888 X 8888\n"
+ "+1 513 899-1888 x 11111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}