# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=)(\t)(\w+\s\w+)(\t)(\d{4,5})|(\t)(\w+)(\t)(\d{4,5})"
test_str = ("2015 64 Fiat 500 S Hatchback 1.2 Manual Petrol Silver White 13000 £7,495\n"
"2012 12 Fiat 500 Lounge Hatchback 1.2 Manual Petrol White 29000 £5,495\n"
"2014 14 Fiat Panda Pop Hatchback 1.2 Manual Petrol White 30000 £4,695\n"
"2009 09 Fiat 500 Pop Hatchback 1.2 Manual Petrol Yellow 31000 £4,295")
subst = ", $2$6, $4$8 mls"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.