const regex = /(?<=)(\t)(\w+\s\w+)(\t)(\d{4,5})|(\t)(\w+)(\t)(\d{4,5})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=)(\\t)(\\w+\\s\\w+)(\\t)(\\d{4,5})|(\\t)(\\w+)(\\t)(\\d{4,5})', 'g')
const str = `2015 64 Fiat 500 S Hatchback 1.2 Manual Petrol Silver White 13000 £7,495
2012 12 Fiat 500 Lounge Hatchback 1.2 Manual Petrol White 29000 £5,495
2014 14 Fiat Panda Pop Hatchback 1.2 Manual Petrol White 30000 £4,695
2009 09 Fiat 500 Pop Hatchback 1.2 Manual Petrol Yellow 31000 £4,295`;
const subst = `, $2$6, $4$8 mls`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);