import Foundation
let pattern = #"^[Ii][Nn][Vv][Oo][Ii][Cc][Ee](?:[[:punct:]]*\s*)*(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Part Lot.: SIM
Telex Release.: SIM
Sea Waybill.: SIM
L/C(Cart. Crédito).: SIM
DU.: SIM - TEST Fer 15:11
PIP.: SIM - pip
MOZ.: SIM
PIV.: SIM - TESTE 123
Incoterms.: SIM
SKU Espelho.: SIM
Inspeção.: SIM
Etiqueta.: SIM
Invoice.: .: teste Fer 15:11
Packing list.: teste Fer 15:11
teste Lisa 15:11
Quantidade CNTR.: SIM - 000123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)