const regex = /^[Ii][Nn][Vv][Oo][Ii][Cc][Ee](?:[[:punct:]]*\s*)*(.*)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[Ii][Nn][Vv][Oo][Ii][Cc][Ee](?:[[:punct:]]*\\s*)*(.*)$', 'g')
const str = `Part Lot.: SIM
Telex Release.: SIM
Sea Waybill.: SIM
L/C(Cart. Crédito).: SIM
DU.: SIM - TEST Fer 15:11
PIP.: SIM - pip
MOZ.: SIM
PIV.: SIM - TESTE 123
Incoterms.: SIM
SKU Espelho.: SIM
Inspeção.: SIM
Etiqueta.: SIM
Invoice.: .: teste Fer 15:11
Packing list.: teste Fer 15:11
teste Lisa 15:11
Quantidade CNTR.: SIM - 000123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}