re = /(?:.*:: )?([\w.]+)\)?/m
str = '(@org.jetbrains.annotations.NotNull :: java.lang.String)
(java.lang.String)
java.lang.String'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end