package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:.*:: )?([\w.]+)\)?`)
var str = `(@org.jetbrains.annotations.NotNull :: java.lang.String)
(java.lang.String)
java.lang.String`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}