$re = '/(?:.*:: )?([\w.]+)\)?/m';
$str = '(@org.jetbrains.annotations.NotNull :: java.lang.String)
(java.lang.String)
java.lang.String';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);