import Foundation
let pattern = ##"((^|\s)#(.*)$)|(^\n)|(\n(\s|)+#(.*)$)|([\n\s]+#.*)|([\n\s]{2,}$)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#This RegEx removes inline comments and blank lines in python code!
# This will save you tokens and time when using GPT to help code and debug.
import requests
import os
#Define vars
def add(a, b):
return a + b
# print results
result = add(2, 3)
print(result) # Output: 5
print("Complete")
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)