package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((^|\s)#(.*)$)|(^\n)|(\n(\s|)+#(.*)$)|([\n\s]+#.*)|([\n\s]{2,}$)`)
var str = `#This RegEx removes inline comments and blank lines in python code!
# This will save you tokens and time when using GPT to help code and debug.
import requests
import os
#Define vars
def add(a, b):
return a + b
# print results
result = add(2, 3)
print(result) # Output: 5
print("Complete")
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}