re = /((^|\s)#(.*)$)|(^\n)|(\n(\s|)+#(.*)$)|([\n\s]+#.*)|([\n\s]{2,}$)/m
str = '#This RegEx removes inline comments and blank lines in python code!
# This will save you tokens and time when using GPT to help code and debug.
import requests
import os
#Define vars
def add(a, b):
return a + b
# print results
result = add(2, 3)
print(result) # Output: 5
print("Complete")
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result