import Foundation
let pattern = #"process\s+(\w+|\"[^\"]+\"|'[^']+')\s*{((.|\n|\r)*)}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
nextflow.enable.dsl=2
// params.module_dir = '.'
params.dbs_dir = '/mnt/OmicNAS/dd/alphafold/dbs'
params.max_template_date = '2020-05-14'
params.db_preset = 'reduced_dbs'
params.model_preset = 'monomer'
params.outdir = './'
params.cachedir = '/mnt/OmicNAS/cache/alphafold'
process ALPHAFOLD {
conda "${moduleDir}/environment.yml"
echo true
maxForks 1
stageInMode 'copy'
storeDir "${params.cachedir}"
publishDir "${params.outdir}", mode: 'copy'
input:
path fasta
output:
path "*", emit: outputs
script:
"""
python3 ${moduleDir}/docker/run_docker.py \
--fasta_paths=${fasta} \
--max_template_date=${params.max_template_date} \
--model_preset=${params.model_preset} \
--db_preset=${params.db_preset} \
--data_dir=${params.dbs_dir} \
--output_dir=\$PWD
"""
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)