$re = '/[A-Z]*,/';
$str = 'JOSE CARLOS RAMON, RODRIGUEZ SOSA.';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;