use strict;
my $str = 'JOSE CARLOS RAMON, RODRIGUEZ SOSA.';
my $regex = qr/[A-Z]*,/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";