re = /[\x{1F000}-\x{1FFFF}|\x{20a0}-\x{32ff}|\x{fe4e5}-\x{fe4ee}|\x{200D}]+/m
str = '🙌🏻
1F64C 1F3FC sd
😈
🏿
👩🏾🤝👨🏿
👩🏾🤝👨🏿
👨👩👦'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end