#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\x{1F000}-\x{1FFFF}|\x{20a0}-\x{32ff}|\x{fe4e5}-\x{fe4ee}|\x{200D}]+"
Local $sString = "🙌🏻" & @CRLF & _
"1F64C 1F3FC sd" & @CRLF & _
"😈" & @CRLF & _
"🏿" & @CRLF & _
"👩🏾🤝👨🏿" & @CRLF & _
"👩🏾🤝👨🏿" & @CRLF & _
"👨👩👦"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")