import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\x{1F000}-\\x{1FFFF}|\\x{20a0}-\\x{32ff}|\\x{fe4e5}-\\x{fe4ee}|\\x{200D}]+";
final String string = "🙌🏻\n"
+ "1F64C 1F3FC sd\n"
+ "😈\n"
+ "🏿\n"
+ "👩🏾🤝👨🏿\n"
+ "👩🏾🤝👨🏿\n"
+ "👨👩👦";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}