import Foundation
let pattern = #"(?:[1-5][0-9]{5,}|6(?:[1-4][0-9]{4,}|5(?:[1-4][0-9]{3,}|5(?:[1-2][0-9]{2,}|3(?:[1-5][0-9]{1,}|[6-9][0-9]*)|[4-9][0-9]{1,})|[6-9][0-9]{2,})|[6-9][0-9]{3,})|[7-9][0-9]{4,})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
12
23
25
100
100000
123
65534
65536
67000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)