$re = '/(?:[1-5][0-9]{5,}|6(?:[1-4][0-9]{4,}|5(?:[1-4][0-9]{3,}|5(?:[1-2][0-9]{2,}|3(?:[1-5][0-9]{1,}|[6-9][0-9]*)|[4-9][0-9]{1,})|[6-9][0-9]{2,})|[6-9][0-9]{3,})|[7-9][0-9]{4,})/m';
$str = '12
23
25
100
100000
123
65534
65536
67000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);