using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[1-5][0-9]{5,}|6(?:[1-4][0-9]{4,}|5(?:[1-4][0-9]{3,}|5(?:[1-2][0-9]{2,}|3(?:[1-5][0-9]{1,}|[6-9][0-9]*)|[4-9][0-9]{1,})|[6-9][0-9]{2,})|[6-9][0-9]{3,})|[7-9][0-9]{4,})";
string input = @"12
23
25
100
100000
123
65534
65536
67000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}