$re = '/^(?!(http)).*\.(png|jpg|jpeg)$/mi';
$str = 'http://123.png
1213.png
/123.jpg
666.png
https://2.png
./2.png
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);