const regex = /^(?!(http)).*\.(png|jpg|jpeg)$/mgi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(http)).*\\.(png|jpg|jpeg)$', 'mgi')
const str = `http://123.png
1213.png
/123.jpg
666.png
https://2.png
./2.png
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}