#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!(http)).*\.(png|jpg|jpeg)$"
Local $sString = "http://123.png" & @CRLF & _
"1213.png" & @CRLF & _
"/123.jpg" & @CRLF & _
"666.png" & @CRLF & _
"https://2.png" & @CRLF & _
"./2.png" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")