import Foundation
let pattern = #"\{(.*?[a-zA-Z]+.*?)\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hello_mister,_Hello
{ Jack }
ASD___asdfffasd
{this}{exam}{problem}{is}{boring}
Whatsup_ddd_sup
{Dude}
HeypalHey______how_ya_how_doin_how
{first}{second}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)