$re = '/\{(.*?[a-zA-Z]+.*?)\}/';
$str = 'Hello_mister,_Hello
{ Jack }
ASD___asdfffasd
{this}{exam}{problem}{is}{boring}
Whatsup_ddd_sup
{Dude}
HeypalHey______how_ya_how_doin_how
{first}{second}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);