// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{(.*?[a-zA-Z]+.*?)\}").unwrap();
let string = "Hello_mister,_Hello
{ Jack }
ASD___asdfffasd
{this}{exam}{problem}{is}{boring}
Whatsup_ddd_sup
{Dude}
HeypalHey______how_ya_how_doin_how
{first}{second}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}