re = /STARTKEYWORD (.+?)(?:$| ENDKEYWORD$)/m
str = 'STARTKEYWORD some text I want to extract ENDKEYWORD
STARTKEYWORD some text I want to extract'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end