$re = '/STARTKEYWORD (.+?)(?:$| ENDKEYWORD$)/m';
$str = 'STARTKEYWORD some text I want to extract ENDKEYWORD
STARTKEYWORD some text I want to extract';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);