package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)STARTKEYWORD (.+?)(?:$| ENDKEYWORD$)`)
var str = `STARTKEYWORD some text I want to extract ENDKEYWORD
STARTKEYWORD some text I want to extract`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}