# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<timestamp>\d{4}\/\d{2}\/\d{2} \d{2}:\d{2}:\d{2}) \[(?<level>.*)\]\ (?<process_id>\d*)#(?<thread_id>\d*): (?<message>.*)"
test_str = ("2022/03/02 08:28:02 [notice] 6888#0: using the \"epoll\" event method\n"
"2022/03/02 08:28:02 [notice] 6888#0: start worker processes\n"
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7234\n"
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7235\n"
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7236\n"
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7237\n"
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7238\n"
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7239\n"
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7240\n"
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7241\n"
"2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6943\n"
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6942 exited with code 0\n"
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6943 exited with code 0\n"
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6944 exited with code 0\n"
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6945 exited with code 0\n"
"2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received\n"
"2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6942\n"
"2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6946\n"
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6940 exited with code 0\n"
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6946 exited with code 0\n"
"2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received\n"
"2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6939\n"
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6939 exited with code 0\n"
"2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received\n"
"2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6941\n"
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6941 exited with code 0\n"
"2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.