import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<timestamp>\\d{4}\\/\\d{2}\\/\\d{2} \\d{2}:\\d{2}:\\d{2}) \\[(?<level>.*)\\]\\ (?<process_id>\\d*)#(?<thread_id>\\d*): (?<message>.*)";
final String string = "2022/03/02 08:28:02 [notice] 6888#0: using the \"epoll\" event method\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: start worker processes\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: start worker process 7234\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: start worker process 7235\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: start worker process 7236\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: start worker process 7237\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: start worker process 7238\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: start worker process 7239\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: start worker process 7240\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: start worker process 7241\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6943\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: worker process 6942 exited with code 0\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: worker process 6943 exited with code 0\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: worker process 6944 exited with code 0\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: worker process 6945 exited with code 0\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6942\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6946\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: worker process 6940 exited with code 0\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: worker process 6946 exited with code 0\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6939\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: worker process 6939 exited with code 0\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6941\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: worker process 6941 exited with code 0\n"
+ "2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}