#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<timestamp>\d{4}\/\d{2}\/\d{2} \d{2}:\d{2}:\d{2}) \[(?<level>.*)\]\ (?<process_id>\d*)#(?<thread_id>\d*): (?<message>.*)"
Local $sString = "2022/03/02 08:28:02 [notice] 6888#0: using the "epoll" event method" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: start worker processes" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7234" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7235" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7236" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7237" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7238" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7239" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7240" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: start worker process 7241" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6943" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6942 exited with code 0" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6943 exited with code 0" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6944 exited with code 0" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6945 exited with code 0" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6942" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6946" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6940 exited with code 0" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6946 exited with code 0" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6939" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6939 exited with code 0" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: signal 17 (SIGCHLD) received from 6941" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: worker process 6941 exited with code 0" & @CRLF & _
"2022/03/02 08:28:02 [notice] 6888#0: signal 29 (SIGIO) received"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")