const regex = /(?m)^:\S+:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^:\\S+:', 'gm')
const str = `:name-of-an-attribute:
:name-of-an-attribute: value of the attribute
:url-org: https://example.org/projects
:url-project: {url-org}/project-name
https://docs.asciidoctor.org/asciidoc/latest/attributes/attribute-entries/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}