#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^:\S+:"
Local $sString = ":name-of-an-attribute:" & @CRLF & _
":name-of-an-attribute: value of the attribute" & @CRLF & _
":url-org: https://example.org/projects" & @CRLF & _
":url-project: {url-org}/project-name" & @CRLF & _
"" & @CRLF & _
"https://docs.asciidoctor.org/asciidoc/latest/attributes/attribute-entries/" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")