package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^:\S+:`)
var str = `:name-of-an-attribute:
:name-of-an-attribute: value of the attribute
:url-org: https://example.org/projects
:url-project: {url-org}/project-name
https://docs.asciidoctor.org/asciidoc/latest/attributes/attribute-entries/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}