// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]+([.]([0-9]){1,2})*$").unwrap();
let string = "3
44
55.5
66.66
777
3,3
.4
.55
-7
89.80
9.234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}