#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]+([.]([0-9]){1,2})*$"
Local $sString = "3" & @CRLF & _
"44" & @CRLF & _
"55.5" & @CRLF & _
"66.66" & @CRLF & _
"777" & @CRLF & _
"3,3" & @CRLF & _
".4" & @CRLF & _
".55" & @CRLF & _
"-7" & @CRLF & _
"89.80" & @CRLF & _
"9.234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")