package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+([.]([0-9]){1,2})*$`)
var str = `3
44
55.5
66.66
777
3,3
.4
.55
-7
89.80
9.234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}