import Foundation
let pattern = #"(?s)(?<=\<span class=\"highlight highlight--wrapping\"\>)(.*?)(?=\<\/span\>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div>... <span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span> (David Cantwell for Forbes)
On a cool summer afternoon at Dublin's Heuston Station, <span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span>, 81...<br> slowly limped out of the station completely unnoticed. And that's just how <span class="highlight highlight--wrapping">Feeney</span> likes it.
<span class="highlight highlight--wrapping">Chuck</span> <span class="highlight highlight--wrapping">Feeney</span> is the James ...</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)