using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<=\<span class=\""highlight highlight--wrapping\""\>)(.*?)(?=\<\/span\>)";
string input = @"<div>... <span class=""highlight highlight--wrapping"">Chuck</span> <span class=""highlight highlight--wrapping"">Feeney</span> (David Cantwell for Forbes)
On a cool summer afternoon at Dublin's Heuston Station, <span class=""highlight highlight--wrapping"">Chuck</span> <span class=""highlight highlight--wrapping"">Feeney</span>, 81...<br> slowly limped out of the station completely unnoticed. And that's just how <span class=""highlight highlight--wrapping"">Feeney</span> likes it.
<span class=""highlight highlight--wrapping"">Chuck</span> <span class=""highlight highlight--wrapping"">Feeney</span> is the James ...</div>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}